[Xenomai] Porting xenomai 2.6.3 and ipipe to 3.12 kernel

Gilles Chanteperdrix gilles.chanteperdrix at xenomai.org
Wed Apr 2 00:01:44 CEST 2014


On 04/01/2014 11:45 PM, Lennart Sorensen wrote:
> On Tue, Apr 01, 2014 at 10:52:31PM +0200, Gilles Chanteperdrix wrote:
>> On 04/01/2014 09:40 PM, Lennart Sorensen wrote:
>>> On Tue, Apr 01, 2014 at 09:35:24PM +0200, Gilles Chanteperdrix wrote:
>>>> On 04/01/2014 03:12 PM, Lennart Sorensen wrote:
>>>>> On Tue, Apr 01, 2014 at 12:52:44PM +0200, Gilles Chanteperdrix wrote:
>>>>>> The way I test it is by running xeno-regression-test, using dohell with
>>>>>> LTP to create a load. Note that the latency result given by
>>>>>> xeno-regression-test should not be taken into account as switchtest is
>>>>>> running concurrently and creates large non-preemptible sections,
>>>>>> xeno-regression-test is more a stress test.
>>>>>
>>>>> I will see if I can find the invocation to run that then.
>>>>>
>>>>> I let cyclictest, switchtest and latency running the last 8 hours,
>>>>> and latency test currently says:
>>>>>
>>>>> RTD|     -0.814|      2.441|      7.486|       0|     0|     -2.116|     20.182
>>>>>
>>>>> That seems decent at least.
>>>>>
>>>>
>>>> I use:
>>>> xeno-regression-test -l "dohell -s 192.168.0.5 -m /mnt -l /ltp"
>>>>
>>>> Where the machine with ip 192.168.0.5 has the "discard" service enabled
>>>> (port 9, available in inetd), an usb key is mounted on /mnt, and LTP is
>>>> installed in /ltp.
>>>
>>> I get an error when I use the -s option.
>>
>> Probably because the machine with the IP address you pass after -s does
>> not have the "discard" service enabled in inetd.conf
> 
> I thought I had.

Do you have the nc command available?

> 
> root at omap5:~# grep RTIPC /boot/config-3.12-1-dra7xx 
> CONFIG_XENO_DRIVERS_RTIPC=m
> CONFIG_XENO_DRIVERS_RTIPC_XDDP=y
> CONFIG_XENO_DRIVERS_RTIPC_IDDP=y
> CONFIG_XENO_DRIVERS_RTIPC_BUFP=y
> 
> Maybe I forgot to load the module....  Yep that was it.
> 
> Then I got to this:
> 
> Started child 14296: /usr/lib/xenomai/testsuite/latency xeno-regression-test -l dohell -s 10.200.19.25 -m /mnt -l /mnt -t 2

I woud say you forgot the quotes around the dohell command, so the -m
option gets passed to latency instead of dohell.

-- 
                                                                Gilles.




More information about the Xenomai mailing list