[Xenomai] OMAP L138

Gilles Chanteperdrix gilles.chanteperdrix at xenomai.org
Thu Apr 3 01:31:33 CEST 2014


On 04/03/2014 12:37 AM, Peter Howard wrote:
> On Wed, 2014-04-02 at 09:24 +0200, Gilles Chanteperdrix wrote:
>> On 04/02/2014 04:59 AM, Peter Howard wrote:
>>> Hi,
>>>
>>> I'm interested in running xenomai on a TI-OMAP L138 board.  I found the
>>> following thread in the archives:
>>>
>>> http://www.xenomai.org/pipermail/xenomai/2010-January/018898.html
>>>
>>> where someone was working on porting ipipe and xenomai to that board.
>>> However, the thread ended with problems still unresolved, and the patch
>>> in the thread (just the changes for ipipe) isn't in the ipipe
>>> repository.
>>>
>>> Does anyone know if this work was completed or just faded into the
>>> ether?
>>
>> We never merged a patch for this processor. And a lot of things changed
>> since that time. If you are interested in porting the I-pipe patch to
>> this processor, see:
>>
>> http://www.xenomai.org/index.php/I-pipe-core:ArmPorting
>>
> 
> Thanks for that.  A further question - the latest "official" kernel for
> that board is 3.3.  Looking through the ipip git repo I can trace back
> against mainline to 3.8, but no further.  Did work in the git repo
> (re-)start then?  Or am I missing things?

I do not know which git you are talking about, but the "official" git,
that is:

http://git.xenomai.org/ipipe.git/refs/heads

goes back to 2.6.19.


-- 
                                                                Gilles.




More information about the Xenomai mailing list