[Xenomai] patch for 3.14 kernel ?

Gilles Chanteperdrix gilles.chanteperdrix at xenomai.org
Fri Apr 11 00:27:28 CEST 2014


On 04/08/2014 03:59 PM, Huub Van Niekerk wrote:
> On Tuesday, April 8, 2014 2:55 PM, Gilles Chanteperdrix
> <gilles.chanteperdrix at xenomai.org> wrote:
> 
> On 04/08/2014 02:47 PM, Huub Van Niekerk wrote:
>> On Monday, April 7, 2014 2:51 PM, Gilles Chanteperdrix
>> <gilles.chanteperdrix at xenomai.org> wrote:
>> 
>> On 04/07/2014 02:21 PM, Huub Van Niekerk wrote:
>>> Hi,
>>> 
>>> After struggling with the 3.10.18 kernel on armhf (both with and 
>>> without the patch), I tried the 3.14 kernel and to my delight
>>> some issues are solved: the clock runs fine again, roscore and
>>> top work great, while they kept failing on 3.10.18.
>> 
>>> I would say you have a timer issue, or perhaps the same issue
>>> with SD-card as Andreas. Have you tried turning off the options I
>>> said Adreas to disable yesterday? (dynamic ticks and high res
>>> timers)?
>> 
>>> When the system is stuck, do you still see the timer interrupt
>>> count incrementing in /proc/interrupts? Same question for the MMC
>>> interrupts.
>> 
>>> Since you are the one having the issue, you will have to do the 
>>> investigation. If you do not do that, do not expect the issue to 
>>> magically go away.
>> 
>> 
>>> So my question is if (or when) there will be a patch for the 3.14
>>> kernel line ?
>> 
>>> I work for the I-pipe patch for the ARM architecture on my free
>>> time. So, I do things when I want to, without any deadline, and
>>> certainly not under pressure.
>> 
>> Right now I can't test anything under the 3.10.18 kernel since for
>> some weird reason (which has nothing to do with Xenomai) my network
>> and USB (combined on my board) is off. With the same configuration
>> file, the 3.14 kernel works fine.
>> 
> 
>> In 3.10 kernel, a new configuration disabled by default is the USB
>> PHY. You need to select the USB PHY corresponding to your board. If
>> you want to boot using NFS, you have to enable the PHY as built-in
>> in addition to the built-in network controller. I did that for the
>> pandaboard (which uses the same network adapter as Beagle-XM I
>> believe), and it boots just fine using NFS.
> 
> I had the 3.10.18 kernel working (with xenomai), including the
> smsc95xx, usb phy, usb hid, etc. Just the clock didnt work. For some
> reason now all of USB and networking is off. I already triple-checked
> all options, and so far no solution.

Just had an issue ressembling this on omap4: booting the panda board
with 3.10 using DT fails;  USB is never started, and network controller
never discovered, which since I am booting with NFS means kernel panic.
Booting with the old style board file works, on the other hand. All
other configuration options being the same. I do not know if this is
specific to Xenomai or not.

-- 
                                                                Gilles.




More information about the Xenomai mailing list