[Xenomai] Command line freeze during xeno-regression-test on omap4460

Gilles Chanteperdrix gilles.chanteperdrix at xenomai.org
Mon Apr 14 09:35:00 CEST 2014


On 04/14/2014 09:24 AM, Andreas Glatz wrote:
> 
> On 14 Apr 2014, at 08:13, Gilles Chanteperdrix wrote:
> 
>> On 01/06/2014 04:30 PM, Andreas Glatz wrote:
>>> Hi,
>>>
>>> I managed to produce a kernel (v3.8.13) with xenomai 2.6.3 ipipe  
>>> patch and
>>> rootfs (debian wheezy) with xenomai 2.6.3 libraries for my  
>>> Pandaboard ES
>>> (omap4460). The simple regression test, which only calls dd during  
>>> the
>>> switchtest, works fine. However the regression test with the linux  
>>> test
>>> project (ltp-full-20130904) scripts causes some sort of system lock  
>>> up.
>>> After that I only can ctrl-c xeno-regression-test (i.e.  
>>> switchtest), which,
>>> however, doesn't help to regain console access (neigher over  
>>> ethernet nor
>>> serial).
>>
>> Hi,
>>
>> I finally ran some tests with SD card: I booted my pandaboard using  
>> NFS
>> as usual, but ran the xeno-test script passing the mount point of  
>> the SD
>> card to dohell's -m option. And I could not reproduce any issue. The
>> kernel I used is 3.14, the configuration is omap2plus_defconfig.
>>
> 
> OK, brilliant. I'll give that a try. I'm assuming that you tested with  
> the git tag 'raw/ipipe-3.14.0' ?

It is a branch actually, but yes.

-- 
                                                                Gilles.




More information about the Xenomai mailing list