[Xenomai] Some Information About compilation Xenomai and RT Patches

Gilles Chanteperdrix gilles.chanteperdrix at xenomai.org
Tue Jun 24 01:41:25 CEST 2014


On 06/23/2014 12:04 PM, Stoidner, Christoph wrote:
> 
> Original ipipe-3.10.18 without Preempt-RT works without any problem.
> The problem occurs only in combination of my Preempt-RT merge and
> enabled FCSE in guaranteed mode.
> 
> Since unmodified ipipe-3.10 does not show the problem I assume
> unmodified ipipe-3.14 also does not show the problem. Or do you think
> 3.14 brings some more details?

I definitely fixed some FCSE issues in the ipipe-3.14 branch, mostly
when FCSE is enabled without CONFIG_IPIPE. Now if ipipe-3.10.18 has no
issues, whereas mixing Prempt-rt in makes some issues appear, I would
suggest looking carefully at the changes introduced by the preempt-rt
patch with regard to mm handling.

-- 
                                                                Gilles.




More information about the Xenomai mailing list