[Xenomai] Support of Beagleboard xm rev C on 3.14-ipipe

Arnaud Degroote arnaud.degroote at isae.fr
Wed Jun 25 10:11:29 CEST 2014


On 24/Jun - 20:31, Gilles Chanteperdrix wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On 06/24/2014 02:21 PM, Arnaud Degroote wrote:
> > On 24/Jun - 08:29, Gilles Chanteperdrix wrote:
> >> -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
> >> 
> >> On 06/24/2014 08:23 AM, Arnaud Degroote wrote:
> >>> On 24/Jun - 01:45, Gilles Chanteperdrix wrote:
> >>>> -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
> >>>> 
> >>>> On 06/23/2014 01:18 PM, Arnaud Degroote wrote:
> >>>>> On 23/Jun - 11:22, Gilles Chanteperdrix wrote:
> >>>>>> On 06/23/2014 11:08 AM, Arnaud Degroote wrote:
> >>>>>>> Hi list,
> >>>>>>> 
> >>>>>>> I'm trying to deploy a 3.14 kernel on my BeagleBoard XM
> >>>>>>> rev C but got several issues. So, first question, it
> >>>>>>> is supposed to be supported or am I somewhere in a grey
> >>>>>>> zone ?
> >>>>>>> 
> >>>>>>> Let describe more precisely the configuration and the 
> >>>>>>> symptom. - linux-ipipe branch ipipe-3.14 - xenomai
> >>>>>>> 2.6.3 + some patches from 2.6 branch (including 
> >>>>>>> d1d00e0acd29bb5f9023494a883a7fa0def40917 
> >>>>>>> 41cb1f73814d1094e0ea75ccbbd23ff01280787e 
> >>>>>>> 7a48019268d7e1157ebb072b88f6683425f0c7c5 
> >>>>>>> f00d22eca6277e780c19a5d5ecd2ed0e23dabafe )
> >>>>>> 
> >>>>>> It is supposed to work, could you try again with the
> >>>>>> xenomai 2.6 git?
> >>>>>> 
> >>>>> 
> >>>>> Hi Gilles,
> >>>>> 
> >>>>> I just tested against 2.6-git and observe the same
> >>>>> behaviours.
> >>>>> 
> >>>>> Best regards,
> >>>>> 
> >>>> Could you post your configuration?
> >>> 
> >>> Sure, see the attached defconfig. It is basically yocto base
> >>> arm kernel + xenomai (and some kernel hacking option).
> >>> 
> >>> 
> >> Could you try to turn off CONFIG_NO_HZ ?
> > 
> > Without CONFIG_NO_HZ, it hangs repeatably during the boot (in the
> > same place than with CONFIG_NO_HZ without CONFIG_DEBUG_LOCK_ALLOC,
> > so this last option is more a timing workaround than a "real fix").
> > See the attached defconfig and boot log.
> 
> Do you have the same problem if you boot using NFS instead of an SD card?
> 

Using root on nfs does not seem to change the problem. It still hangs in
the same place.

Cheers,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: Digital signature
URL: <http://www.xenomai.org/pipermail/xenomai/attachments/20140625/22613eb7/attachment.sig>



More information about the Xenomai mailing list