[Xenomai] ipipe-gch-ipipe-3.0-imx6q latency

eric ericvic at 163.com
Tue Dec 15 08:05:40 CET 2015


ok,thanks  very much!
At 2015-12-15 14:17:46, "Gilles Chanteperdrix" <gilles.chanteperdrix at xenomai.org> wrote:
>On Tue, Dec 15, 2015 at 08:54:56AM +0800, eric wrote:
>> >
>> >So the latency is below 100us, much less than 500us. It seems a bit
>> >high though, do you have any debug option enabled? Do you run this
>> >with a real-time load?
>> >
>> >-- 
>> >					    Gilles.
>> >https://click-hack.org
>> 
>>         I can not run real-time load ,it always stop  the flowing step.  So  i use some other load program .And I do not  enabled  debug option.
>> root at imx6qdlsolo:/opt/x3/bin# ./xeno-test
>> Started child 29228: /bin/sh /usr/xenomai/bin/xeno-test-run-wrapper ./xeno-test
>> ++ echo 0
>> ++ testdir=/opt/imx6/smp3/xenomai-3.0.1/x3/bin
>> ++ /opt/imx6/smp3/xenomai-3.0.1/x3/bin/smokey --run
>> arith OK
>> bufp OK
>> iddp OK
>> leaks OK
>
>I was rather thinking about running the user-space load which
>creates high latencies with your own latency test.
>
>But if you are interested in running xeno-test, you should check its
>syntax:
>- either by running it with the -h or --help argument
>- or by checking its manual page, either on your disk or on xenomai
>website:
>https://xenomai.org/documentation/xenomai-3/html/man1/xeno-test/
>- or by reading the page where we explain how we do the benchmarks
>we publish:
>https://xenomai.org/2014/07/benchmarking-with-xeno-test/
>
>Regards.
>
>-- 
>					    Gilles.
>https://click-hack.org


More information about the Xenomai mailing list