[Xenomai] RTCAN problem with PEAK PCIe & miniPCIe

Wuwei He whe at neocisinc.com
Tue Dec 29 17:16:26 CET 2015


Hello, all

I have a problem with the PEAK PCIe card: I could never receive CAN
messages and can only send one message.


Using /usr/xenomai/bin/rtcansend and rtcanrecv:
When receiving, RX_Counter does not increase.
When sending, TX_Counter increase to 1, and message is received from the
receive end. Then sending a second message, it gets blocked and no
response. Checking with /proc/rtcan/devices, no error status though.

I am using Xenomai 2.6.3, Linux kernel 3.5.7, under Ubuntu 12.04.
Same results for two different PC -- hardware. Tested with PEAK dual PCIe
and dual miniPCIe.
Tried with SHARED_IRQ enabled. When not enabled, the devices won't be
loaded.
Also, when using dual PCI card, no such problems. Same error behavior with
dual PCIe and miniPCIe.

Would any one knows what kind of problem I am in?

Any information or links could be very much helping.
Thanks!

Wuwei "Will" He
Miami FL
US


More information about the Xenomai mailing list