[Xenomai] IPIPE_LOCK Problem

Varun Deshpande varun9485 at gmail.com
Tue Apr 12 11:55:15 CEST 2016


Hello all,

I am trying to compile Xenomai 3.0.2 with Kernel 4.1.18. I am running a
32bit Ubuntu(14.04.04). I configured the kernel and changed the following
options

1) Enable loadable module support  →   Forced module loading (Press Y)
2) Enable loadable module support  →   Forced module unloading (Press Y)
3) Xenomai/cobalt   →  Drivers  →   RTnet  →   Protocol Stack  →  RTmac
Layer  →   NoMAC discipline for RTmac (Press M)
4) Xenomai/cobalt   →  Drivers  →   RTnet  →   Drivers  →  (For All
requried Drivers Press M){Exclude Others by pressing N)
5) Xenomai/cobalt   →  Drivers  →   RTnet  →  Add­Ons  → Real­Time
Capturing Support (Press M)
6) Power management and ACPI options  →  ACPI (Advanced Configuration &
Power Interface)Support  →  Processor(Press N)
7) Power management and ACPI options  →  APM (Advanced Power Management)
BIOS support (Press N)
8) Power management and ACPI options  →   CPU Frequency scaling   →CPU
Frequency scaling (Press N)
9) Power management and ACPI options  →  CPU Idle  →  CPU idle PM support
(Press N)
10) Networking support  →  Networking Options  →  Timestamping in
PHYdevices (Press Y)
11) Device Drivers  →  Input device support  →  Miscellaneous devices→   PC
Speaker support (Press N)
12) Device Drivers  →  Staging Drivers  (Press N)
13) Processor type and features -->  Continuous Memory Allocator (Press N)
14) Processor type and features --> Transparent Huge Page Support (Press N)
15) Processor type and features --> Allow for memory compaction (Press N)
16) Processor type and features --> Page Migration (Press N)


After saving the file , when I start compiling the kernel, after 60 minutes
of compilation I get following error.
Note : I have also tried by only changing kernel options from point 1 to
point 12 in xenomai-stable (Before xenomai 3.0.2 was released) but I get
the same error.
Also I dont get any error of such error when I tried it on kernel 3.18.20.
Please guide me in this regard, Following is the Error :

In file included from include/linux/spinlock.h:92:0,
                 from include/linux/seqlock.h:35,
                 from include/linux/time.h:5,
                 from include/linux/stat.h:18,
                 from include/linux/module.h:10,
                 from sound/soc/intel/atom/sst/sst.c:22:
sound/soc/intel/atom/sst/sst.c: In function ‘sst_restore_shim64’:
include/linux/ipipe_lock.h:83:2: error: expected expression before ‘do’
  do {        \
  ^
include/linux/spinlock.h:272:2: note: in expansion of macro
‘PICK_SPINUNLOCK_IRQRESTORE’
  PICK_SPINUNLOCK_IRQRESTORE(lock, flags)
  ^
include/linux/spinlock.h:374:2: note: in expansion of macro
‘raw_spin_unlock_irqrestore’
  raw_spin_unlock_irqrestore(lock, flags)
  ^
sound/soc/intel/atom/sst/sst.c:373:2: note: in expansion of macro
‘spin_unlock_irqrestore’
  spin_unlock_irqrestore(&ctx->ipc_spin_lock, irq_flags);
  ^
make[5]: *** [sound/soc/intel/atom/sst/sst.o] Error 1
make[4]: *** [sound/soc/intel/atom/sst] Error 2
make[3]: *** [sound/soc/intel/atom] Error 2
make[2]: *** [sound/soc/intel] Error 2
make[1]: *** [sound/soc] Error 2
make: *** [sound] Error 2

Best Regards
Varun Deshpande


More information about the Xenomai mailing list