[Xenomai] Assertion failed on "test posix_clock" on some executions of xeno-test.

Andrea andrea.schiappacasse at camelotbio.com
Fri Apr 22 10:51:34 CEST 2016


Hello,

I'm currently using Xenomai 3.0.2, under kernel 4.1.8  with i-pipe patch.
I just noticed that I'm experiencing an error on some run of xeno-test.

The reported error is:
*posix-clock.c:420, assertion failed: diff < 1000000000*
*/usr/xenomai/bin/smokey: test posix_clock failed: Invalid argument*

The specific function where the assert is issued in posix-clock.c is
"clock_decrease_after_periodic_timer_first_tick(void)"

On multiple executions it is not reproducible, I am wondering if anybody
could hint me to the source of the problem on my system.

On two consecutives run this is what I get from the test:


RUN A (no error):
*./xeno-test -l "dohell -s 192.168.0.5 -m /mnt -l /ltp" -t 2*
Started child 4475: /bin/bash /usr/xenomai/bin/xeno-test-run-wrapper
./xeno-test -t 2
++ echo 0
++ testdir=/usr/xenomai/bin
++ /usr/xenomai/bin/smokey --run
arith OK
bufp skipped (no kernel support)
cpu_affinity skipped (no kernel support)
iddp skipped (no kernel support)
leaks OK
net_packet_dgram skipped (no kernel support)
net_packet_raw skipped (no kernel support)
net_udp skipped (no kernel support)
*posix_clock OK*
[...]


RUN B (assertion failed):

* ./xeno-test -l "dohell -s 192.168.0.5 -m /mnt -l /ltp" -t 2*
Started child 3117: /bin/bash /usr/xenomai/bin/xeno-test-run-wrapper
./xeno-test -t 2
++ echo 0
++ testdir=/usr/xenomai/bin
++ /usr/xenomai/bin/smokey --run
arith OK
bufp skipped (no kernel support)
cpu_affinity skipped (no kernel support)
iddp skipped (no kernel support)
leaks OK
net_packet_dgram skipped (no kernel support)
net_packet_raw skipped (no kernel support)
net_udp skipped (no kernel support)
*posix-clock.c:420, assertion failed: diff < 1000000000*
*/usr/xenomai/bin/smokey: test posix_clock failed: Invalid argument*


Thank you in advance for your kind attention,

Andrea


More information about the Xenomai mailing list