[Xenomai] kernel 3.12

Ran Shalit ranshalit at gmail.com
Sun Apr 24 09:21:50 CEST 2016


On Mon, Apr 18, 2016 at 5:30 PM, Lennart Sorensen
<lsorense at csclub.uwaterloo.ca> wrote:
> On Mon, Apr 18, 2016 at 05:28:26PM +0300, Ran Shalit wrote:
>> On Mon, Apr 18, 2016 at 4:56 PM, Ran Shalit <ranshalit at gmail.com> wrote:
>> > On Mon, Apr 18, 2016 at 4:54 PM, Lennart Sorensen
>> > <lsorense at csclub.uwaterloo.ca> wrote:
>> >> On Mon, Apr 18, 2016 at 04:47:46PM +0300, Ran Shalit wrote:
>> >>> Is there a link to that patch ? I would like to try it in my kernel.
>> >>> We can't upgrade the kernel at this point, so we must use (3.12).
>> >>
>> >> Well I put my patches on one of my web pages:
>> >>
>> >> http://csclub.uwaterloo.ca/~lsorense/xenomai-3.12/
>> >>
>> >> At least that might give you a starting point.
>> >>
>> >> That is that last version of the patch before we moved to 3.14.
>> >>
>> >> --
>> >> Len Sorensen
>> >
>>
>>
>> Hi Len,
>>
>> One more on this, if I may.
>> The kernel I am using is 3.12.0,
>> Does it mean that the patch (3.12.31) can be applied on 3.12.0 kernel
>> ( or can it only be applied on 3.12.31 kernel) ?
>
> I used 3.12.31, but it should be very minor tweaking to get it on 3.12.0.
>
> --
> Len Sorensen

Hi Lan,

We intend to use ipipe with zynq (we already have 3.12.0 kernel used with zynq).
Do you think the patch should be relevant for zynq ?
I see that xilinx have their own patch , but it is for older kernel 2.6.3
http://www.wiki.xilinx.com/Xenomai+for+Zynq#Xenomai for Zynq-7000 AP
SoC Linux--Patch

I also see that in git there is ipipe for 3.12.0
http://git.xenomai.org/ipipe-gch.git/log/?h=raw/for-ipipe-3.12.0
But again I am unsure if it is relevant for zynq too.

Thank you for the time,
Ran



More information about the Xenomai mailing list