[Xenomai] Long time system slow down on imx6

Marco Baracchi cormabara at yandex.com
Mon Dec 12 15:31:02 CET 2016


   Sorry I hope this is the correct way to add a mail to this thread
   inside mailing list:

   Â

   What you mean with "lost wakeup problem" ?

   Â

   What we are checking is a timer tick missing:

   Â

   root at deimo-staubli ~$ cat /proc/timer_list

   Timer List Version: v0.6

   HRTIMER_MAX_CLOCK_BASES: 3

   now at 158072087097365 nsecs

   Â

   cpu: 0

   clock 0:

   Â  .base:Â Â Â Â Â Â  80ba8380

   Â  .index:Â Â Â Â Â  0

   Â  .resolution: 1 nsecs

   Â  .get_time:Â Â  ktime_get

   Â  .offset:Â Â Â Â  0 nsecs

   active timers:

   #0: <80ba88a0>, tick_sched_timer, S:01

   # expires at 158034760000000-158034760000000 nsecs [in -37327097365 to
   -37327097365 nsecs]

   #1: <8fb57f40>, hrtimer_wakeup, S:01

   # expires at 158034782298842-158034782348842 nsecs [in -37304798523 to
   -37304748523 nsecs]

   #2: <8f201ad0>, hrtimer_wakeup, S:01

   # expires at 159434496114473-159434496164473 nsecs [in 1362409017108 to
   1362409067108 nsecs]

   #3: <8f20bad0>, hrtimer_wakeup, S:01

   # expires at 159439053136473-159439057697464 nsecs [in 1366966039108 to
   1366970600099 nsecs]

   clock 1:

   Â  .base:Â Â Â Â Â Â  80ba83b8

   Â  .index:Â Â Â Â Â  1

   Â  .resolution: 1 nsecs

   Â  .get_time:Â Â  ktime_get_real

   Â  .offset:Â Â Â Â  1481376344107425663 nsecs

   active timers:

   clock 2:

   Â  .base:Â Â Â Â Â Â  80ba83f0

   Â  .index:Â Â Â Â Â  2

   Â  .resolution: 1 nsecs

   Â  .get_time:Â Â  ktime_get_boottime

   Â  .offset:Â Â Â Â  0 nsecs

   active timers:

     .expires_next   : 158034760000000 nsecs

     .hres_active    : 1

     .nr_events      : 22078740

     .nr_retries     : 51929

     .nr_hangs       : 0

     .max_hang_time  : 0 nsecs

     .nohz_mode      : 0

     .idle_tick      : 0 nsecs

     .tick_stopped   : 0

     .idle_jiffies   : 0

     .idle_calls     : 0

     .idle_sleeps    : 0

   Â  .idle_entrytime : 0 nsecs

     .idle_waketime  : 0 nsecs

     .idle_exittime  : 0 nsecs

   Â  .idle_sleeptime : 0 nsecs

   Â  .iowait_sleeptime: 0 nsecs

     .last_jiffies   : 0

     .next_jiffies   : 0

     .idle_expires   : 0 nsecs

   jiffies: 15773475

   Â

   Â

   Tick Device: mode:Â Â Â Â  1

   Per CPU device: 0

   Clock Event Device: mxc_timer1

   max_delta_ns:Â Â  4294967295

   min_delta_ns:Â Â  85000

   mult:Â Â Â Â Â Â Â Â Â Â  1

   shift:Â Â Â Â Â Â Â Â Â  0

   mode:Â Â Â Â Â Â Â Â Â Â  3

   next_event:Â Â Â Â  158034760000000 nsecs

   set_next_event: xnarch_next_htick_shot

   set_mode:Â Â Â Â Â Â  xnarch_switch_htick_mode

   event_handler:Â  hrtimer_interrupt

   retries:Â Â Â Â Â Â Â  0

   As you can see the next event is in the past, timer mxc_timer1 seems to
   have missed a tick.

   Â

   You mean your system is locked into a SELECT system call ?

   1ms is the period of your periodic thread ?

   Â

   Â

   12.12.2016, 12:00, "xenomai-request at xenomai.org"
   <xenomai-request at xenomai.org>:

     Send Xenomai mailing list submissions to
     Â Â Â Â Â Â Â Â [1]xenomai at xenomai.org
     To subscribe or unsubscribe via the World Wide Web, visit
     Â Â Â Â Â Â Â Â [2]https://xenomai.org/mailman/listinfo/xenomai
     or, via email, send a message with subject or body 'help' to
     Â Â Â Â Â Â Â Â [3]xenomai-request at xenomai.org
     You can reach the person managing the list at
     Â Â Â Â Â Â Â Â [4]xenomai-owner at xenomai.org
     When replying, please edit your Subject line so it is more specific
     than "Re: Contents of Xenomai digest..."
     Today's Topics:
     Â Â Â 1. Re: Long time system slow down on imx6 (Johann Obermayr)
     --------------------------------------------------------------------
     --
     Message: 1
     Date: Mon, 12 Dec 2016 11:16:33 +0100
     From: Johann Obermayr <[5]johann.obermayr at sigmatek.at>
     To: [6]Xenomai at xenomai.org
     Subject: Re: [Xenomai] Long time system slow down on imx6
     Message-ID: <[7]f07822d2-e30a-d394-bae6-bdf776c0f03a at sigmatek.at>
     Content-Type: text/plain; charset=utf-8; format=flowed
     Am 09.12.2016 um 23:42 schrieb Marco:

     Â Â Â Â Â We are notice a very strange problem on a imx6 with kernel
     Â Â Â Â Â Linux3.0.35-4.1.0 + xenomai_2.6.4. After machine runs for
     8 - 10 hours
     Â Â Â Â Â we found the system blocked in may different ways (user
     interface
     Â Â Â Â Â tcp/ip interface ecc..)
     Â Â Â Â Â ?
     Â Â Â Â Â We check into /proc/timer_list and we found the next event
     was
     Â Â Â Â Â scheduled in the past.
     Â Â Â Â Â ?
     Â Â Â Â Â We found some items about timer blocked but all the
     patches indicated
     Â Â Â Â Â was already applied.
     Â Â Â Â Â ?
     Â Â Â Â Â Maybe someone have seen a similar problem ?
     Â _______________________________________________
     Â Xenomai mailing list
     Â [8]Xenomai at xenomai.org
     Â [9]https://xenomai.org/mailman/listinfo/xenomai

     Hello,
     i don't known if it is the same problem.
     But we search a lost wakeup problem with "select" and a short
     timeout. (1ms)
     Regards
     Â Â Â Johann
     ------------------------------
     Subject: Digest Footer
     _______________________________________________
     Xenomai mailing list
     [10]Xenomai at xenomai.org
     [11]https://xenomai.org/mailman/listinfo/xenomai
     ------------------------------
     End of Xenomai Digest, Vol 56, Issue 11
     ***************************************

References

   1. mailto:xenomai at xenomai.org
   2. https://xenomai.org/mailman/listinfo/xenomai
   3. mailto:xenomai-request at xenomai.org
   4. mailto:xenomai-owner at xenomai.org
   5. mailto:johann.obermayr at sigmatek.at
   6. mailto:Xenomai at xenomai.org
   7. mailto:f07822d2-e30a-d394-bae6-bdf776c0f03a at sigmatek.at
   8. mailto:Xenomai at xenomai.org
   9. https://xenomai.org/mailman/listinfo/xenomai
  10. mailto:Xenomai at xenomai.org
  11. https://xenomai.org/mailman/listinfo/xenomai


More information about the Xenomai mailing list