[Xenomai] RTnet fixes - testers needed (Philippe Gerum)

Philippe Gerum rpm at xenomai.org
Fri Dec 8 15:42:55 CET 2017


On 12/08/2017 03:16 PM, Stéphane Ancelot wrote:
> Hi,
> 
> Do you know which release introduced this problem ?
> 

It never worked.

> Regards,
> 
> S.Ancelot
> 
> 
> Le 08/12/2017 à 12:03, Andreas Glatz a écrit :
>>> I pushed a pile of RTnet fixes in a WIP branch of the official repo
>>> (wip/rtnet-fixes). Most of them address invalid direct references to
>>> user memory from kernel space (instead of properly copying back and
>>> forth via the copy_from/to_user interface), which are badly wrong at any
>>> rate, even breaking the kernel on SMAP-enabled x86 platforms.
>>>
>>> Most I/O calls were affected, ioctl, sendmsg and recvmsg. I'm still in
>>> the early process of testing the changes gradually, which involves
>>> running tests for all socket levels (RAW, DGRAM) and protocols (INET,
>>> PACKET) enabled.
>> I think that's exactly what I was seeing when running 4.9 Linux +
>> Xenomai 3 + RTnet on i.MX6.
>>
>>> If you depend on RTnet and want to help with testing, you may want to
>>> give this branch a try. Any help with reviewing the changes would be
>>> beneficial to the project too.
>>>
>> I shall try and give it a spin this weekend.
>>
>> Thanks.
>>
>> A.
>>
>> _______________________________________________
>> Xenomai mailing list
>> Xenomai at xenomai.org
>> https://xenomai.org/mailman/listinfo/xenomai
> 
> 
> _______________________________________________
> Xenomai mailing list
> Xenomai at xenomai.org
> https://xenomai.org/mailman/listinfo/xenomai


-- 
Philippe.



More information about the Xenomai mailing list