[Xenomai] [BUILDROOT] Xeno-test don’t work : Xenomai: /dev/rtheap is missing

thierry.xenomai43 at yahoo.com thierry.xenomai43 at yahoo.com
Thu Feb 2 14:36:23 CET 2017


Hello,
To use Xenomai 2.6.4 on my Raspberry Pi 3 (ARM64) I want get a good I-pipe patch
On this URL I found several patch for Linux 4.1 and ARM 64bit : https://xenomai.org/downloads/ipipe/v4.x/arm64/older-BROKEN-DO-NOT-USE/
I think that is a problem beacause I have 4.4.21-v7 linux kernel.
Where can I download the good patch for?

regardsThierry

 

    Le Jeudi 2 février 2017 14h02, "thierry.xenomai43 at yahoo.com" <thierry.xenomai43 at yahoo.com> a écrit :
 

 I forget to say that my Embeded Linux Kernel is the 4.4.21-v7

     

    Le Jeudi 2 février 2017 11h49, "thierry.xenomai43 at yahoo.com" <thierry.xenomai43 at yahoo.com> a écrit :
 

   Hello,
I build Embeded linux for Paspberry Pi 3 with Buildroot-2016.11.2 suite. I tested Linux part and all is ok.Now I would like to use Xenomai 2.6.4 in my project.
In menuconfig, on "package>Real-Time" , I selected :    
   
   - Xenomai Userspace;
   
   - Install testsuite
   
   - Native skin lib
   
   - POSIX lib

   
I not used patch during the build.
When I want use ‘xeno-test" on my target, I have this echo :" Started child 152: /bin sh /usr/bin/xeno-test-run-wrapper /usr/bin/xeno-test /usrbin/xeno-test-run-wrapper: /usr/bin/xeno-test: line 43: can’t creat /proc/xenomai/latency: nonexistent directory+ echo 0+ :+ /usr/bin/arithXenomai: /dev/rtheap is missing(chardev, major=10 minor=254)"I see on web that I need to use I-pipe patch. Where can I found this patch for Raspbery3, and Xenomai 2.6.4 ?
Best regards,Thierry.


   


More information about the Xenomai mailing list