[Xenomai] memory allocation performance in kernel ipipe

Stéphane Ancelot sancelot at numalliance.com
Mon Jan 16 10:45:03 CET 2017


Hi,

after analysis, the problem was coming from Xorg intel i965 driver and 
xorg 1.16.

Migrating to recent xorg 1.19 kernel solved the problem.

Regards,

S.Ancelot


Le 09/12/2016 à 17:20, Philippe Gerum a écrit :
> On 12/09/2016 04:28 PM, Stéphane Ancelot wrote:
>
>>>> I remember I have not had this problem with previous kernel releases
>>>> (3.16.x) .
>> I tried kernel 3.16.7,3.18.20 and 4.1.18.
> So there is eventually an issue with your app on a 3.16 kernel, unlike
> the initial post suggested?
>
>> this happens in 32 bit or 64 bit, both SMP kernel
>>
>> I made 2 traces to open with kernelshark (please advice if it is a
>> problem). you have to filter task : chg_cst
>>
>> this one is when the problem is happening using the computer display.
>>
>> https://drive.google.com/open?id=0B1JEDrsMi1E1YkZja1dsWTFRcDQ
>>
>> and this one is when it runs fine through a ssh -X session.
>> https://drive.google.com/open?id=0B1JEDrsMi1E1WUVyOUFEbFdzWkk
>>
>> comparing both tasks  diagram , I can sea that when it does not work,
>> the task is interrupted for a long time.
>> in other case, no interruption in it's activity diagram.
> Interrupted by which activity, where, at which timestamp of this massive
> trace file? Please give us accurate, detailed and precise information
> for us to help, I don't think anyone on this list could invest much time
> diving into a 95Mb trace dump.
>



More information about the Xenomai mailing list