[Xenomai] Latency test fails after in a Xenomai patched Ostro XT linux distro - part 2

Nitin Kulkarni nitink at kth.se
Sat Mar 4 05:30:46 CET 2017


After the below things happened I added a regular user (nitin) to the allowed_group parameter file in /sys/module/xenomai/parameters/allowed_group


Then executed the latency test to get this message :


nitin at intel-corei7-64:/usr/bin$ /usr/xenomai/bin/latency
   0"000.000| WARNING: [main] cannot open RTDM device /dev/rtdm/memdev-private: Permission denied
   0"000.000| WARNING: [main] cannot map private umm area: Permission denied
   0"000.000| BUG in init_bind(): [main] (CONFIG_DEVTMPFS_MOUNT not enabled?)

?I must be doing something wrong. Please let me know.

- Nitin


________________________________
From: Nitin Kulkarni
Sent: Saturday, March 4, 2017 4:26 AM
To: xenomai at xenomai.org
Subject: Latency test fails after in a Xenomai patched Ostro XT linux distro


Hi,

I have patched the Xenomai 3.0.3 to an Ostro XT linux distribution and after flashing the image and booting on the Intel Joule board I installed the Xenomai libraries natively. When I run the Latency test it gives this message and stops.


root at intel-corei7-64:~/Xenlib# /usr/xenomai/bin/latency
== Sampling period: 100 us
== Test mode: periodic user-mode task
== All results in microseconds
/usr/xenomai/bin/latency: pthread_create(latency): Operation not permitted

Although I am running as a root user it gives this error. I have not added any user group through the Kernel command line parameter xenomai.allowed_group?.
when I run the command

dmesg | grep -i xenomai


I get this from the Kernel log
[    0.000000] Command line: rootwait console=tty0 xenomai.sysheap_size=256 xenomai.state=enabled xenomai.smi=detect xenomai.smi_mask=1 console=ttyS2,115200 video=efifb maxcpus=4 noxsave reboot=efi kmemleak=off fsck.mode=skip no-ima ro root=PARTUUID=12345678-9abc-def0-0fed-cba987654321 rootfstype=ext4 installer
[    0.000000] Kernel command line: rootwait console=tty0 xenomai.sysheap_size=256 xenomai.state=enabled xenomai.smi=detect xenomai.smi_mask=1 console=ttyS2,115200 video=efifb maxcpus=4 noxsave reboot=efi kmemleak=off fsck.mode=skip no-ima ro root=PARTUUID=12345678-9abc-def0-0fed-cba987654321 rootfstype=ext4 installer
[    0.668993] [Xenomai] scheduling class idle registered.
[    0.669456] [Xenomai] scheduling class rt registered.
[    0.670016] I-pipe: head domain Xenomai registered.
[    0.672804] [Xenomai] Cobalt v3.0.3 (Groovy Cosmic Halo)

?
Please let me know how to handle this issue.

Regards,
Nitin










More information about the Xenomai mailing list