[Xenomai] Won`t build on new Debian Stable

Norbert Lange nolange79 at gmail.com
Tue Oct 10 16:38:50 CEST 2017


Some highly trivial fix attached!
Its strange that this flag is not documented in the manual (I found
out abaout this fix from https://launchpad.net/ubuntu/+source/flint)

Norbert Lange

2017-08-10 11:49 GMT+02:00 Henning Schild <henning.schild at siemens.com>:
> Hi Norbert,
>
> Thanks! In fact that issue has come up before and a similar workaround
> was described. It should be fixed, patches welcome!
>
> Henning
>
> Am Wed, 9 Aug 2017 16:21:02 +0200
> schrieb Norbert Lange <nolange79 at gmail.com>:
>
>> Hello,
>>
>> Building the xenomai package won`t work because debian now defaults to
>> using pie, and the linker will complain with "ld: -r and -pie may not
>> be used together"
>>
>> A workaround for now is to add the flags manually:
>> ../xenomai-3.0.5/configure LDFLAGS=-no-pie CFLAGS="-fno-PIE -fno-pie
>> -no-pie"
>>
>> A real fix would be similar to
>> http://lists.gnu.org/archive/html/bug-grub/2016-11/msg00011.html
>> (no-pie is not supported on old and other compilers)
>>
>> Kind regards,
>> Norbert
>>
>> _______________________________________________
>> Xenomai mailing list
>> Xenomai at xenomai.org
>> https://xenomai.org/mailman/listinfo/xenomai
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-allow-linking-with-pie-as-default.patch
Type: text/x-patch
Size: 1465 bytes
Desc: not available
URL: <http://xenomai.org/pipermail/xenomai/attachments/20171010/21c189ff/attachment.bin>


More information about the Xenomai mailing list