[I-PIPE] ipipe-core-4.9.135-x86-7 released

Jan Kiszka jan.kiszka at siemens.com
Thu Dec 6 08:26:43 CET 2018


On 06.12.18 08:24, duanwujie wrote:
> We use the xenomai 3.0.7 stable version. Is okay for this ?
> 

No, as I said. You need the latest stable/3.0.x branch because you need 
adjustments to the FPU changes.

Jan

> 在 2018/12/6 下午3:21, Jan Kiszka 写道:
>> On 06.12.18 08:18, duanwujie wrote:
>>> I am not so sure, bellow code exist in ipipe-core-4.9.51-x86-2.patch but 
>>> ipipe-core-4.9.135-x86-7.patch didn't。
>>>
>>> arch/x86/include/asm/fpu/internal.h:
>>>
>>> #ifdef CONFIG_IPIPE
>>> static inline union fpregs_state *active_fpstate(struct fpu *fpu)
>>> {
>>> return fpu->active_state;
>>> }
>>> #else
>>> static inline union fpregs_state *active_fpstate(struct fpu *fpu)
>>> {
>>> return &fpu->state;
>>> }
>>> #endif
>>
>> That's because of 
>> https://gitlab.denx.de/Xenomai/ipipe/commit/6152df8928a5a8c3cbba81490109e041a2ca95fd 
>> and is correct.
>>
>> Again: Did you update Xenomai?
>>
>> Jan
>>
> -- 
> *Linx Software Corportaion Sichuan Branch
> Name:wujie duan
> Tel:028-65182023-6202
> E-mail: wjduan at linx-info.com
> *


-- 
Siemens AG, Corporate Technology, CT RDA IOT SES-DE
Corporate Competence Center Embedded Linux



More information about the Xenomai mailing list