[xenomai-images][PATCH 3/3] distro/include: Allow overwrite PREFERRED_VERSION

Q. Gylstorff Quirin.Gylstorff at siemens.com
Tue Aug 27 11:07:52 CEST 2019


From: Quirin Gylstorff <quirin.gylstorff at siemens.com>

To build arm64 PREFERRED_VERSION_linux-xenomai must be
set to 4.14% instead of 4.19 for next. To allow overwrites
by machine configurations change the operator from = to ?=.

Signed-off-by: Quirin Gylstorff <quirin.gylstorff at siemens.com>
---
 conf/distro/include/xenomai-version.inc | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/conf/distro/include/xenomai-version.inc b/conf/distro/include/xenomai-version.inc
index f14f458..524ca39 100644
--- a/conf/distro/include/xenomai-version.inc
+++ b/conf/distro/include/xenomai-version.inc
@@ -14,4 +14,4 @@ XENOMAI_STABLE_VERSION_LIST = "stable 3.0 3.0% 3.0.% 3.0.9"
 XENOMAI_STABLE_KERNEL_VERSION = "4.14%"
 # if PREFERRED_VERSION_xenomai contains any item from XENOMAI_STABLE_VERSION_LIST use
 # XENOMAI_STABLE_KERNEL_VERSION
-PREFERRED_VERSION_linux-xenomai = "${@bb.utils.contains_any('PREFERRED_VERSION_xenomai','${XENOMAI_STABLE_VERSION_LIST}','${XENOMAI_STABLE_KERNEL_VERSION}','${XENOMAI_NEXT_KERNEL_VERSION}',d) }"
+PREFERRED_VERSION_linux-xenomai ?= "${@bb.utils.contains_any('PREFERRED_VERSION_xenomai','${XENOMAI_STABLE_VERSION_LIST}','${XENOMAI_STABLE_KERNEL_VERSION}','${XENOMAI_NEXT_KERNEL_VERSION}',d) }"
-- 
2.20.1




More information about the Xenomai mailing list