Problem with gdb

Jan Kiszka jan.kiszka at siemens.com
Mon Apr 27 07:39:05 CEST 2020


On 26.04.20 14:50, Paolo Minazzi wrote:
> Il 26/04/2020 10:33, Jan Kiszka ha scritto:
>> Can you cross-check with ipipe-core-4.19.114-cip24-arm-08? 4.9 is 
>> unmaintained regarding I-pipe.
> Hi Jan,
> I could try 4.19. But then I would have a complex task to to the porting 
> all of my system to linux-4.19.

If you aren't being a lab device, this would be better anyway in order 
to receive bug fixes for a longer time. As I said: 4.9 is dead, already 
lagging behind. 4.4-cip is still maintained but a bad start for a new 
project.

> 
> I have tried now downgrading xenomai to 3.0.9 with the same ipipe-4.9.38.
> I have seen something changed in xenomai 3.1 about debugging.

Yes, we need 
https://gitlab.denx.de/Xenomai/ipipe-arm/-/commit/5f032ff0126222ee944e4e44ea0c2b49a9c66d02 
and more.

Jan

> With xenomai-3.0.9 gdb seems working OK.
> Tomorrow I will test better and I will post results.
> 
>> How did you build Xenomai (configure options)? How are you building 
>> your demo?
>>
> Xenomai build
> 
> ./scripts/bootstrap --with-core=cobalt
> configure --build=i686-pc-linux-gnu \
> --host=arm-linux-gnueabihf \
> --with-core=cobalt \
> --prefix=$HERE/../$XENOMAI-install \
> CC=arm-linux-gnueabihf-gcc LD=arm-linux-gnueabihf-ld
> make
> 
> Application build
> 
> CROSS=arm-linux-gnueabihf-
> 
> INCLUDES=$(shell sh ../../xenomai-3.1-install/bin/xeno-config 
> --skin=alchemy --cflags)
> LIBS=$(shell sh ../../xenomai-3.1-install/bin/xeno-config --skin=alchemy 
> --ldflags)
> 
> All:
>          $(CROSS)gcc $(INCLUDES) $(LIBS) -o demo demo.c -g
> 
> 
> Kind regards,
> Paolo
> 

-- 
Siemens AG, Corporate Technology, CT RDA IOT SES-DE
Corporate Competence Center Embedded Linux



More information about the Xenomai mailing list