Re: Re: error: implicit declaration of function ‘__OPEN_NEEDS_MODE’

Greg Gallagher greg at embeddedgreg.com
Mon Dec 28 22:12:41 CET 2020


On Mon, Dec 28, 2020 at 4:08 PM Gabriel Dinse via Xenomai <
xenomai at xenomai.org> wrote:

> Hello,
>
> I’m not used to use email this way, but answering your question on the
> hidden email LOL,
> I’m compiling for Raspberry PI 1 B on the environment I showed, following
> this guide:
> https://github.com/harcokuppens/xenomai3_rpi_gpio/blob/master/install/install_xenomai-3-3.0.5_on_rpi1__ipipe_git.txt.
> I also forgot to say I am using WSL2, not a native Ubuntu.
>
> Best regards,
> Gabriel Dinse
>
> This is a fairly old guide, if I read this correctly you are using a 3.18
kernel? I’d recommend using mainline, I’ve compiled for a raspberry Pi 1b
and haven’t seen this. I’ll try it again tonight.

Greg


More information about the Xenomai mailing list