Xenomai RTnet - Kernel module not loading

Benji miethben at b-tu.de
Mon Mar 2 15:49:42 CET 2020


Hi,

non of troubleshooting in the wiki fixed the problem with error -19.
Today i get access to a system with Intel Xeon CPU and compiled the
kernel with same configuration.

It looks like the system is starting Xenomai without any error:

> $ dmesg | grep Xenomai
> [    5.114787] [Xenomai] scheduling class idle registered.
> [    5.114878] [Xenomai] scheduling class rt registered.
> [    5.114984] [Xenomai] disabling automatic C1E state promotion on Intel processor
> [    5.115112] [Xenomai] SMI-enabled chipset found, but SMI workaround disabled
> [    5.115336] I-pipe: head domain Xenomai registered.
> [    5.115968] [Xenomai] Cobalt v3.1 [DEBUG]
>                *** RTnet for Xenomai v3.1 ***


First system i try to get Xenomai working had a Intel Core i7-8550U
working in Thinkpad X1 Carbon.

Is Intel Xeon and Core-i CPUs that different that Xenomai is unable to load?

On 2/27/20 7:55 PM, Jan Kiszka wrote:
> On 27.02.20 19:51, Benji via Xenomai wrote:
>> On 2/27/20 4:51 PM, Greg Gallagher wrote:
>>>>>> I thought system is running on cobalt kernel. But looks like there
>>>>>> is an
>>>>>> initialisation error. What is meaning of error code -19?
>>>>>
>>>>>>> $ dmesg | grep Xenomai
>>>>>>> [ 8.543295] [Xenomai] scheduling class idle registered.
>>>>>>> [ 8.543302] [Xenomai] scheduling class rt registered.
>>>>>>> [ 8.543333] [Xenomai] init failed, code -19
>>>>>
>>>>> I haven't seen that one myself. But check out:
>>>>>
>>>>> https://xenomai.org/pipermail/xenomai/2015-September/thread.html#35066
>>>>>
>>>>> and
>>>>>
>>>>> https://gitlab.denx.de/Xenomai/xenomai/-/wikis/Troubleshooting#no-timer
>>>>>
>>>>>
>>>>> (Although i see the in-page link is broken check the section about
>>>>> timers)
>>>>>
>>>>>
>>>>> Per Öberg
>>>>>
>>>> Hi,
>>>>
>>>> the hint was in the right direction. There is something strange in my
>>>> build process. In kernel configuration i disable options described in
>>>> Xenomai Wiki (like CPU_FREQ, KGDB..). After running 'make bzImage
>>>> modules' and checking .config file, disabled option are enabled again.
>>>>
>>>> Are there dependencies to force enable these option without notice?
>>>>
>>>> Thanks
>>>> Benji
>>>>
>>> Did you use menuconfig? I use menuconfig to disable those options and
>>> it makes it very clear if there are other options that need to be
>>> disabled as well.
>>>
>>> -Greg
>>>
>>
>> I use menuconfig. But some options can't be disabled like CPU_FREQ or
>> page migration. You're right there are warning about enabled options but
>> as i said they can't be disable. So i edit .config file manually to meet
>> requirement from Xenomai wiki.
>>
>> Can somebody provide me a working configuration for x86_64 architecture?
>>
> 
> See https://gitlab.denx.de/Xenomai/xenomai-images for a working image
> and
> https://gitlab.denx.de/Xenomai/xenomai-images/blob/master/recipes-kernel/linux/files/amd64_defconfig
> for a working config.
> 
> Jan
> 

Thanks
Benji



More information about the Xenomai mailing list