[PATCH Dovetail 08/13] cobalt/build: pipeline: select IPIPE layer only if present

Philippe Gerum rpm at xenomai.org
Sat Jan 2 10:33:48 CET 2021


From: Philippe Gerum <rpm at xenomai.org>

We may be able to build against a Dovetail-enabled kernel at some
point, so do not force-enable CONFIG_IPIPE, it might not be there.

At this chance, remove obsolete internal switches and conditions. All
I-pipe implementations depend on the GENERIC_CLOCKEVENTS framework,
and support for the legacy I-pipe V1 API is long gone.

No functional change is introduced.

Signed-off-by: Philippe Gerum <rpm at xenomai.org>
---
 scripts/Kconfig.frag | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

diff --git a/scripts/Kconfig.frag b/scripts/Kconfig.frag
index f2e89a896..319683369 100644
--- a/scripts/Kconfig.frag
+++ b/scripts/Kconfig.frag
@@ -1,8 +1,8 @@
 menuconfig XENOMAI
 	depends on X86_TSC || !X86
 	bool "Xenomai/cobalt"
-	select IPIPE
-	select IPIPE_WANT_APIREV_2
+	select IPIPE if HAVE_IPIPE_SUPPORT
+	select IPIPE_WANT_APIREV_2 if IPIPE
 	default y
 	help
 	  Xenomai's Cobalt core is a real-time extension to the Linux
@@ -30,10 +30,6 @@ comment "or CPU idle features is enabled. Any of these options may"
 comment "cause troubles with Xenomai. You should disable them."
 endif
 
-if !GENERIC_CLOCKEVENTS
-comment "NOTE: Xenomai 3.x requires CONFIG_GENERIC_CLOCKEVENTS"
-endif
-
 config XENO_VERSION_MAJOR
        int
        default @VERSION_MAJOR@
-- 
2.26.2




More information about the Xenomai mailing list