[CXP] some questions about "Common Xenomai Platform"

Philippe Gerum rpm at xenomai.org
Sat Jan 9 10:09:40 CET 2021


Hailongliu <hailongliiu at yeah.net> writes:

> On 1/7/21 11:59 PM, Greg Gallagher wrote:
>> 
>> 
>> On Thu, Jan 7, 2021 at 10:53 AM hailong via Xenomai <xenomai at xenomai.org <mailto:xenomai at xenomai.org>> wrote:
>> 
>>     At 2021-01-04 01:38:04, "Philippe Gerum" <rpm at xenomai.org <mailto:rpm at xenomai.org>> wrote:
>>     >
>>     >Hailongliu via Xenomai <xenomai at xenomai.org <mailto:xenomai at xenomai.org>> writes:
>>     >
>>     >> Hi,
>>     >>
>>     >> I learned the "Common Xenomai Platform" program from this mail-list and wiki
>>     >> of project Xenomai. This is a very attractive plan, as it will port Xenomai for
>>     >> recent LTS kernel(v5.10).
>>     >>
>>     >> I noticed that  March 31, 2021 is the deadline for "CXP", dose that mean we
>>     >> can expect the new features at Xenomai-3.3 ?
>>     >
>>     >Yes, that is the plan. Xenomai 3.3 is going to be the first release
>>     >fully implementing the CXP. Xenomai 4 which is going to use a different
>>     >real-time core will be developed in parallel to Xenomai 3.3, aiming at
>>     >CXP-compliance too. It should be clear that March 31, 2021 is the date
>>     >for completing the CXP specification, not that of any release
>>     >implementing it, which can only happen later by definition.
>>     >
>> 
>>     Will the CXP or Xenomai 4 compatible with RT-patch over time?
>>     In addition,   I learned that the legacy RTOS emulators (such as VxWorks)
>>     will be excluded from Xenomai 3.x , neither Xenomai 4?
>> 
>> That is correct, we don't have the resources to continue to support the RTOS emulators.  I believe it was left open that if someone
>> wants to take this on as a maintainer they could be included.
>> 
>
> Thank you for your kind reply.
>
> Our work team members now are hesitating about which kernel version to choose
> as our development baseline for Xenomai between linux-5.10 and linux-5.4,
> because we find that there is a evl branch based on linux-5.4 but not for
> linux-5.10 currently.

Yes there is, see evlproject.org. evl/master is based on v5.10 mainline.

>
> And we also want to know the compatibility between the Xenomai4 and rt-patch.
>

Compatible.

-- 
Philippe.



More information about the Xenomai mailing list